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Volume 1: Installation Guide 

 

This volume describes the procedures necessary for you, the Coordinator and/or 
Network Administrator to install VISUAL Assurance for implementation on single-
user or network systems. 
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Minimum System Requirements 

1 

This chapter provides an overview of minimum system requirements needed for 
running VISUAL Assurance. 

 
• Microsoft Windows 95 (or later). 

• Personal computer with a 75Mhz Pentium or higher processor. 

• At least 16Mb of memory (32Mb is recommended). 

• Hard disk requirements for the VISUAL Assurance Program. 
Standalone Installation: 
32Mb of free hard drive space. 
 
Workstation Installation: 
20Mb of free hard drive space. 
 
In addition, about 1Mb of additional hard drive space for each Knowledgebase 
installed or created. 

• 3.5-inch high-density (1.44 MB) disk drive. 

• VGA video adapter supported by Microsoft Windows 95 or later (256-color 
video recommended). 

• Laser printer or dot matrix capable of printing graphics at high speed 
recommended. 
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Installation Options 

2 

This chapter provides an overview of installation options available when installing 
VISUAL Assurance. 

Single-User 
The only non-networked method of installing VISUAL Assurance is the single-user 
or standalone setup.  In this setup, your machine holds the executable and the 
data.  Sharing data in this environment is restricted to using the Export and Import 
functions. 

Network 
The most common installation type for VISUAL Assurance is the Network setup.  
The VISUAL Assurance Program, together with the Borland Database Engine, is 
placed on any number of Workstations and the VISUAL Assurance database is 
placed on a database server.  A Network installation requires that the Corporate 
database be installed on a server in accordance with the database vendor’s 
instructions and that an empty VISUAL Assurance database be created.  Please note 
that data can only be loaded after a Workstation installation has been performed.  
Individual Users of VISUAL Assurance install the Program on their own Network-
linked PCs, choosing the Workstation option.  Your machine will require 
approximately 20Mb of hard drive space to be free for this operation. 
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Overview of Installation Steps 

3 

This chapter provides an overview of the installation steps required. 

Single-User 
1. Install VA as per the instructions in Chapter 4.  This will install VA, the 

BDE (Borland Database Engine) and InterBase. 

2. Import the tutorial, both the Knowledgebase and the Assessments.  See 
“Setup (Required)” in either the Tutorial help file or the Tutorial Manual, 
which is on our web site http://www.kilclare.com in Downloads-
>Manuals.  The tutorial files to import are VATUTKB.VAE and 
VATUTAS.VAE and are located in the VISUAL Assurance folder.  The 
KBKey required to import these files is “123456”. 

3. If you have a “Product Key”, this needs to be entered by executing VA 
and then entering the required details in Help->Registration. 

4. Change the login password for the “Admin” User ID.  See the section 
“Change Password” in Chapter 5 of the Administrators Manual. 

5. If you purchased other Knowledgebases, import them. 

6. If you have a legacy VISUAL Assurance system, carry out the steps in 
Chapter 8 - Database Integrity Check Program and Chapter 9 - 
Knowledgebase Conversion Program. 
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Network 
1. Decide if you want to use a common VASERVER.INF file or have a 

separate one for each user.  If a common file is to be used, create an empty 
VASERVER.INF and placed it in a mapped network drive. 
 
One reason for having a separate VASERVER.INF file for each user is 
that the Database Administrator may insist that each user have a distinct 
and separate database access so as to monitor who is connected. 

2. Install VA as per the instructions in Chapter 5.  This will install VA and 
the BDE (Borland Database Engine) on the Workstation. 

3. Steps 4, 5, 6 and 7 should only be done once; skip to step 8 if this is the 
case.  NOTE:  If you decided to use a separate VASERVER.INF file for 
each user then step 6 below needs to be carried out for each user. 

4. Install the VA Utilities, which are on our web site http://www.kilclare.com 
in Downloads->Utilities, by executing file SETUP.EXE.  Follow the on-
line instructions. 

5. Create a Database on the Server as outlined in Chapter 6. 

6. Execute the VA utility VADBPASS (see Steps 6 and 7 in Chapter 6). 

7. Execute the VA utility VADBINIT (see Step 8 in Chapter 6). 

8. Import the tutorial, both the Knowledgebase and the Assessments.  See 
“Setup (Required)” in either the Tutorial help file or the Tutorial Manual, 
which is on our web site http://www.kilclare.com in Downloads-
>Manuals.  The tutorial files to import are VATUTKB.VAE and 
VATUTAS.VAE and are located in the VISUAL Assurance folder.  The 
KBKey required to import these files is “123456”. 

9. If you have a “Product Key”, this needs to be entered by executing VA 
and then entering the required details in Help->Registration.  Registration 
only needs to be entered once, from a single VA installation. 
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10. Change the login password for the “Admin” User ID.  See the section 
“Change Password” in Chapter 5 of the Administrators Manual. 

11. If you purchased other Knowledgebases, import them. 

12. If you have a legacy VISUAL Assurance system, carry out the steps in 
Chapter 8 - Database Integrity Check Program and Chapter 9 - 
Knowledgebase Conversion Program. 
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Single-User Program Installation 

4 

When VISUAL Assurance is installed as a single-user (standalone) application, the 
executable, the Borland Database Engine and Local InterBase are installed on the 
same computer. 

 

NOTES: 

1. You are responsible for the integrity of your data.  You are strongly 
advised to read Chapter 10 - InterBase Server Manager.  

2. VISUAL Assurance installs as a 30-day evaluation.  If you received a 
“Product Key” then you should apply it by starting VISUAL 
Assurance and executing the “Registration” command on the Help 
menu.  

 

To install VISUAL Assurance as a single-user system, perform the following 
installation: 

Single-User Program Installation 
 

1. Download the VISUAL Assurance installation program as instructed to in our 
email. 

2. Select RUN from the Windows start menu and locate the file you downloaded 
by clicking on the <Browse> button, then click the <OK> button. 
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3. If MDAC2.6 is required to install, then after its installation you will be 
informed that the computer will re-boot and continue with the installation of 
VISUAL Assurance. 
 

4. The Welcome screen appears: 

 

5. The Choose Destination Location screen appears.  You will be asked to select 
the folder where the VISUAL Assurance Program will be installed.  The 
installation default is C:\Program Files\Kilclare\VISUAL Assurance.  It is 
recommended that, if you are installing a new version 2.x of VISUAL 
Assurance, you overwrite your existing VA version 2.x.  Choose the <Next> 
button. 
 
Note:  DO NOT INSTALL VA OVER VA1.11, VA1.12 or VA1.5. 
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6. Click the <Next> button.  The Select Program Manager Group screen 
appears: 

 

7. This screen displays a list of folders already created on your system.  The 
default program group name is VISUAL Assurance.  Either select another group 
name from the displayed list, type in a new group name or accept the default 
group name.  Click the <Next> button to continue.  

8. The Select Dictionaries screen appears: 
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9. Select which dictionary or dictionaries you want installed.  Click the <Next> 
button to continue. 

10. The Get Installation Type screen appears: 

 

11. Select Option 2, Single-User, and click the <Next> button 

12. The Start Installation screen appears: 
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13. Click the <Next> button and follow all subsequent screen prompts.  

Once the installation is complete, the Installation Complete screen will appear.  
Choose the <Finish> button.  If the installation detects that a reboot is required 
before VISUAL Assurance will execute correctly, a message will be displayed.  
Click the <Yes> button to allow an immediate reboot or the <No> button to 
reboot at a later stage.  Prior to clicking the <Yes> button, make sure that you 
save the data and close all open applications.  Also, make sure that any DOS 
applications are exited. 
 
When the installation is complete, a functioning copy of VISUAL Assurance 
exists. 

Your default Supervisor user name is ADMIN and your password is 1234. 
Note that the password field is case sensitive.  To change your password, 
refer to the VISUAL Assurance on-line Help. 

14. Return to Step 2 in the Single-User section of Chapter 3. 
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Workstation Program Installation 

5 

When VISUAL Assurance is installed for use on a network, the executable, together 
with the Borland SQL Links, is installed on a workstation and the database is 
installed on a server.  An installed executable, however, does not include any data. 

 

NOTES: 

1. You must still rely on the server for data, security and backups.  
Chapter 10, “InterBase Server Manager”, may be of use, 
notwithstanding that you are using another vender’s Database 
Engine. 

2. VISUAL Assurance installs as a 30-day evaluation.  If you received a 
“Product Key” then you should apply it by starting VISUAL 
Assurance and executing the “Registration” command on the Help 
menu.  

 

To install VISUAL Assurance on a Workstation attached to a network server, 
perform each of the following three installations in the order given: 

Client/Server Database Installation 
The Client/Server Database must be installed in accordance with the vendor’s 
instructions.  Refer to Chapter 6 – Database Installation/Setup for details of the 
Client/Server databases VISUAL Assurance supports. 
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Create file VaServer.inf 
 

Prior to installing the program on Workstations, the file VaServer.inf must be 
created.  This file will ultimately contain encrypted information that will allow you 
access to the Client/Server Database.  Initially, an empty VaServer.inf file must be 
created on a server and in a folder to which all VISUAL Assurance network users 
have read only access.  Furthermore, the VaServer.inf file must have write 
permission so that the user of the utility, VADBPASS, may update the information 
in this file.  Once VaServer.inf has been updated, its permissions may be set to read 
only. 

Workstation Program Installation 
 

To install VISUAL Assurance on a Workstation attached to a network server, 
perform the following steps: 

1. The Client/Server Database must first be installed in accordance with the 
vendor’s instructions and the file VaServer.inf must be created.  Refer to the 
sections Client/Server Database Installation and Create File VaServer.inf 
above. 

2. Download the VISUAL Assurance installation program as instructed to in our 
email. 

3. Select RUN from the Windows start menu and locate the file you downloaded 
by clicking on the <Browse> button, then click the <OK> button. 

4. If MDAC2.6 is required to install, then after its installation you will be 
informed that the computer will re-boot and continue with the installation of 
VISUAL Assurance. 

5. The Welcome screen appears: 
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6. The Choose Destination Location screen appears.  You will be asked to select 
the folder where the VISUAL Assurance Program will be installed.  The 
installation default is C:\Program Files\Kilclare\VISUAL Assurance.  It is 
recommended that, if you are installing a new version 2.x of VISUAL 
Assurance, you overwrite your existing VA version 2.x.  Choose the <Next> 
button.  
 
Note:  DO NOT INSTALL VA OVER VA1.11, VA1.12 or VA1.5. 
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7. The Select Program Manager Group screen appears:  

 

8. This screen displays a list of groups already created on your system.  The 
default program group name is VISUAL Assurance.  Either select another group 
name from the displayed list, type in a new group name or accept the default 
group name.  Click the <Next> button to continue.  

10. The Select Dictionaries screen appears:  
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Select which dictionary or dictionaries you want installed.  

11. The Get Installation Type screen appears:  

 

12. Select Option 1, Workstation, and click the <Next> button. 

14. The Choose Location of File VASERVER.INF screen appears:  
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15. Select the location of the file, VaServer.inf, which was previously created on 
the server.  Click the <Next> button.  The existence of the file VaServer.inf will 
be verified.  

16. Click the <Next> button.  The Start Installation screen appears: 

 

17. Click the <Next> button and follow all subsequent screen prompts.  

Once the installation is complete, the Installation Complete screen will appear. 
Choose the <Finish> button.  If the installation detects that a reboot is required 
before VISUAL Assurance will execute correctly, a message will be displayed. 
Click the <Yes> button to allow an immediate reboot or the <No> button to 
reboot at a later stage.  Prior to clicking the <Yes> button, make sure that you 
save the data and close all open applications.  Also, make sure that any DOS 
applications are exited.  
 
When the installation is complete, a functioning copy of VISUAL Assurance 
exists without access to the database. 

Your default Supervisor user name is ADMIN and your password is 1234. 
Note that the password field is case sensitive.  To change your password, 
refer to the VISUAL Assurance on-line Help. 

18. Return to Step 3 in the Network section of Chapter 3. 
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Database Installation/Setup 

6 

This chapter contains information on installing and setting up the VISUAL Assurance 
Database. 

This chapter is for Network Administrators.   

 

Once the steps outlined below are completed, you can access the data. 

The utility files referred to in this Chapter are installed as follows: 

1. If instructed to in our email, download the VISUAL Assurance Utilities 
installation program. 

2. Select RUN from the Windows start menu and locate the file you downloaded 
by clicking on the <Browse> button, then click the <OK> button. 

3. Follow the on-screen instructions. 
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The Utility files are as follows: 

VADBPASS.EXE Utility to update files VALOCAL.INF and/or 
VASERVER.INF.  The entries in these INF files are 
required by VISUAL Assurance for Database access. 

VADBINIT.EXE Utility to seed the VISUAL Assurance Database with 
core data.  The following files are required by this 
utility and will be installed by the Utilities Disk:  
ASSPREF.TXT, CHOICE.TXT, CURRENCY.TXT, 
KBPREF.TXT, PLAN.TXT and SYSPREF.TXT. 

Local Client/Server Installation 
VISUAL Assurance can be connected to the following Local Client/Server 
Database: 

Local InterBase  Borland Inc. (32 bit version) 

Network Client/Server Installation 
VISUAL Assurance can be connected to the following Network Client/Server 
Databases: 

InterBase  5.6    Borland Inc. 

Oracle 7.3.x/8.0.x/8i   Oracle Inc. 

SQL Server 6.5 SP4+/7.0  SP1+/2000 Microsoft Inc. 

Sybase 11.9.x/12.5   Sybase Inc. 

The Client/Server Database must be installed in accordance with the vendor’s 
instructions. 
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Once the Client/Server Database has been installed, perform the following steps: 

1. If you selected Borland InterBase as the Database Type go to step 5 below;  
otherwise, go to step 2. 
 
Note: 
The Borland InterBase installation may be simplified by copying the 
database file, VaDB.gdb, to the required server location.  This file is 
installed by the Program installation when selecting the Single-User option. 

2. Create a VISUAL Assurance database in accordance with the vendor’s 
instructions. 
 

3. VISUAL Assurance does not require a separate login for each user.  Only a 
single login ID is necessary, however, this login ID must have privileges to 
create and drop tables and to insert and delete records.  Give this login ID a 
password of your choice. 
 
VISUAL Assurance requires that the following database specific properties be 
set:  
 
Sybase:  
 Check the Truncate log on checkpoint in the Options tab.  
 
For versions 11.9.2 and above, ensure that all the tables have the “data rows” 
locking scheme. 
 
Oracle: 
Depending on the version of Oracle, edit either INITORCL.ORA or INIT.ORA 
and add the line OPEN_CURSORS = 99, if it does not exist.  

4. On each Workstation, install the Client side software in accordance with the 
vendor’s instructions and test the connectivity between the Client and Server. 
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5. On each Workstation, check the BDE parameters are correctly set as detailed 
in Chapter 7. 

6. Execute application VADBPASS.EXE. 

 

 
Note that the top half of the Database Access Setup screen refers to the Local 
Database Configuration and that the bottom half refers to the Remote Database 
Configuration. 
 
Local Database Configuration: 
Changes to fields in the Local Database Configuration section are applied to file 
VaLocal.inf. 
 
You should not make changes to any of the fields in this section, unless 
instructed to do so by the VISUAL Assurance help desk. 
 
  
Remote Database Configuration: 
Changes to fields in the Remote Database Configuration section are applied to 
file VaServer.inf. 
 
In the User ID, Password and Confirm Password fields, enter the same values 
that were used when the database was created.  See step 3 above. 

VISUAL Assurance 21 



Installation Guide 

 
From the RDBMS group, select the database type you are using as your 
Client/Server Database. 
 
In the Server field, enter the name of the server on which the Client/Server 
Database resides.  Note:  For Oracle, this field must be set to the “name of 
the server for service” and, for InterBase this must be the full path to the 
database file (e.g. SERVER_NAME:\apps\data\vadb.gdb) 
 
In the Database field, enter the name of the database.  This name must match 
the name you gave the database when setting it up.  See step 2 above.  Note:  
For Oracle and InterBase, this field must be empty. 
 
Click the <Update> button to save the changes to the VaServer.inf file. 

7. Click the <Close> button to exit VADBPASS. If you selected the Borland 
InterBase as the Database Type and you have a copy of the database file, 
VaDB.gdb, the installation may be simplified by copying this file to the 
required server location and skipping step 8. 

8. Execute application VADBINIT.EXE.  Click the <Create VA98 Database> 
button.  Once this has completed, click the <Close> button. 

 

9. Very Important:  Protect programs VADBPASS and VADBINIT against 
unauthorized use.  Executing VADBINIT a second time will destroy and data 
already in the VISUAL Assurance database.  
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Borland Database Engine Setup 

7 

When installing a new version of VISUAL Assurance, you may have to ensure that 
you have connectivity to the Client/Server Database. 

This chapter is for Network Administrators.   

 

To connect to the Client/Server Database, do the following: 

Execute the BDE Administrator application from the Start|Programs or the BDE 
Administrator icon on the Control Panel.  With the “Databases” tab, in the left 
hand panel, selected, select the relevant alias (e.g. VaDB_Oracle).  The parameters 
for the selected alias are displayed in the right hand panel.  To edit a parameter, 
click in the field to the right of the parameter.  Some parameter fields are editable, 
others are set by selecting from a pull-down list.  To save your changes, select the 
command, Object->Apply. 

In order to connect to a particular database, some parameters may have to be 
modified and/or set for that databases alias. 

SQL Server: 
In the left hand panel, select the “Databases” tab and then highlight the alias 
“VaDB_MSSQL”.  The parameters of this alias will display in the right hand panel. 
Set the following parameters: 

1. Blob Size to 1000 

To save your changes, select Object->Apply.  To test connectivity with the 
database, press the “+” on the left of the “VaDB_MSSQL” alias.  If connectivity 
exists the “+” will change to a green square.  Close the connection by clicking the 
“Close” icon on the toolbar.  To exit the BDE, select Object->Exit. 
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Sybase: 
 In the left hand panel, select the “Databases” tab and then highlight the alias 
“VaDB_Sybase”.  The parameters of this alias will display in the right hand panel. 
Set the following parameters: 

1. Blob Size to 1000 

In the left hand panel, select the “Configuration” tab and open the Configuration-
>Drivers->Native folder and highlight Sybase. 
If necessary, set the following parameters: 

1. DLL32 to SQLSSC32.DLL 

To save your changes, select Object->Apply. 

If you wish to test connectivity with the database from within the BDE then the 
following parameters also need to be set and the changes saved,  

1. Database Name – Enter the same name that was given when the database 
was created. 

2. Server Name – Enter the actual name of the server. 

To test connectivity, press the “+” on the left of the “VaDB_Sybase” alias.  If 
connectivity exists the “+” will change to a green square.  Close the connection by 
clicking the “Close” icon on the toolbar.  To exit the BDE, select Object->Exit. 

Oracle: 
In the left hand panel, select the “Databases” tab and then highlight the alias 
“VaDB_Oracle”.  The parameters of this alias will display in the right hand panel. 
Set the following parameters: 

1. Blob Size to 1000 

2. Enable Integers to True 

3. Net Protocol to TNS 
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In the left hand panel, select the “Configuration” tab and open the Configuration-
>Drivers->Native folder and highlight Oracle. 
If necessary, set the following parameters: 

1. DLL32 to SQLORA8.DLL 

2. Vendor Init to OCI.DLL 

To save your changes, select Object->Apply.  

If you wish to test connectivity with the database from within the BDE then the 
following parameter also needs to be set and the change saved,  

1. Server Name – Enter the actual name of the server for service. 

To test connectivity, press the “+” on the left of the “VaDB_Oracle” alias.  If 
connectivity exists the “+” will change to a green square.  Close the connection by 
clicking the “Close” icon on the toolbar.  To exit the BDE, select Object->Exit. 
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Database Integrity Check Program 

8 

You need to ensure that a database integrity check is carried out before running 
the CONVERT program. 

Run the VISUAL Assurance v1.5 Database Maintenance Utility Program.  The 
Maintenance Utility screen appears: 

Menu bar 
Title bar 

 

Tab 

To run the Database Integrity Check Program, you must perform the following 
steps: 

1. Highlight the Libraries tab: 

(a)  from the Catalog menu bar option, select and execute the Index command. 

(b) click the <File Check> button. 
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2. Highlight the Master Kb tab: 

(a)  click the <Index> button. 

(b) click the <File Check> button. 

(c)  click the <Integrity Check> button. 

3. Highlight the Entities tab: 

(a)  from the Catalog menu bar option, select and execute the Index command. 

(b) click the <File Check> button. 

4. Highlight the Working Kb tab:  

(a)  click the <Index> button. 

(b) click the <File Check> button. 

(c)  click the <Integrity Check> button. 

5. For each of the remaining tabs (VA Users, Templates and Params):  

(a)  from the Catalog menu bar option, select and execute the Index command. 

(b) click the <File Check> button. 

6. Click the Menu bar Exit command. 

After completing ALL the integrity check steps above, run the CONVERT program 
so that the Knowledgebases can be converted from the 1.5 FoxPro format to the 
new Client/Server format.  For details refer to Chapter 9 - Knowledgebase 
Conversion Program. 
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 Knowledgebase Conversion Program 

9 

When installing a new version of VISUAL Assurance, you will have to convert all 
the Knowledgebases on your System to enable them to be successfully loaded into 
your new version of VISUAL Assurance. 

NOTES: 

1. The CONVERT program is a single-user license only.  As such, it may 
ONLY be installed on one computer.  The installation is also password 
protected. 

2. It is strongly advised that the following procedure be followed when 
converting legacy Knowledgebases:  

a. Place ALL Master and Working Knowledgebases on a single system 
and convert them in a single session. 

b. If (a) above is not possible then, you MUST ensure that the conversion 
of the Master Knowledgebases is done in an orderly manner.  Working 
Knowledgebases may then be converted on an as needed basis.  

c. Ensure that there are no empty/blank Master Knowledgebases as these 
cannot be converted and, more importantly, Working Knowledgebases 
that are attached to blank Masters cannot be converted. 

d. VA1.5 Working Knowledgebases that have been tailored cannot be 
converted.  To help you rationalize your Master and Working 
Knowledgebases use the utility, VATCHECK.EXE, that comes with 
VA1.5. 

FAILURE TO COMPLY WITH THE ABOVE PROCEDURE WILL 
RESULT IN PROBLEMS. 
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For example: 
If the Convert Program is run on 10 different machines that have the same 
Master Knowledgebases on them, then you will end up with 10 different 
Knowledgebases.  Furthermore, the Assessments (Working 
Knowledgebases) of each will have no relationship to each other and thus 
comparative analysis cannot be done.  

3. The CONVERT utility allows users to select between two alternative methods 
of converting Assessments.  A check box titled “Convert data to Compliance 
type” controls whether Assessments are of type Risk/Exposure or Compliance. 
If the box is unchecked, the Type of Assessment in the Assessment Properties 
dialog will be set to Risk/Exposure; if it is checked the Type of Assessment in 
the Assessment Properties dialog will be set to Compliance.   By running the 
Convert program twice you may set some Assessments to be of type 
Risk/Exposure and others of type Compliance. 

4. The CONVERT utility allows users to select between two alternative methods 
of converting knowledgebases.   

The standard method  
Areas, Objectives and Considerations of VA 1.50 are mapped to areas, 
objectives and considerations in VA 2.  However, since considerations in VA 2 
form the 4th level, A 3rd level, risk, is inserted between objectives and 
considerations.  For each objective, one risk item is inserted.  The “one liner” 
title of this item is derived from the title of its parent objective.  The “full 
question” text is as follows: “Effective controls should be established, 
implemented and maintained to assist in achieving the stated objective and to 
mitigate the risk(s) to its achievement”.  The master texts of the parent objective 
are copied to the risk level.  Working knowledgebase texts of the parent 
objective are ignored. 

The ERM (Enterprise Risk Management) method 
Areas, Objectives and Considerations of VA 1.50 are mapped to Areas, 
Objectives and Risks in VA 2.  For each risk item in VA 2, one consideration is 
inserted.  The “one liner” title of this item and its “full question” text appear as: 
”Activity contributes to management of risk and achievement of objective”.  
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The response to and importance of this consideration are the same as that at 
level 3 in VA1.50.  The master texts of the parent risk are copied to the 
Consideration level.  Working knowledgebase texts of the parent Risk are 
ignored. 

Upon installation of the Convert Utility, only the standard method of conversion 
is available.  In order to have both methods available, insert the following line 
in the [CONV] section of the file VA2.INI: 
AllowConvertERM = Y 

By inserting the above line into VA2.INI, a check box titled “Map level 3 to 
level 4” will display.  If the box is left unchecked, the ERM method of 
conversion is used.  Otherwise, the standard method is used.  Please note that if 
a master was converted using a particular method, all working knowledgebases 
that are attached to it, have to be converted using the same method. 

5. The CONVERT utility also allows two methods of converting texts from VA 1.50 
to VA 2. 

Standard text conversion method: 
When a user converts a master/working knowledgebase pair, the conversion 
utility searches first through the text fields of the master.  All text types that 
contain some text, are assumed to be master text fields and all get converted.  
The conversion then scans the texts in the working KB and converts only the 
texts that are not master texts.  

Alternative text conversion method: 
In some cases, users have modified master texts in the working KB.  If the 
standard text conversion were to be used, the modified texts would not be 
converted.  In order to overcome this problem, it is possible to use the 
alternative method.  Add the following line to the [CONV] section of the file 
VA2.INI: 
CopyWKBMasterTexts = Y 

When the conversion scans the working KB, it will convert ALL texts.  Those 
texts that are master texts will have the word “Assessor” added to their title.  
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Please note, that in this case, all master texts of VA 1.50 appear twice in the 
converted working knowledgebases.  The original master text appears as an 
“author” text and its counterpart in the working knowledgebase, which may or 
may not have been modified, appears as an “Assessor” text.  

6. The text field “Control/Communication/Monitor Procedure” at the consideration level 
of a Working Knowledgebase in VA 1.50 is converted to the Control procedure/activity 
section of the Implementation form in VA 2. However, it is possible to convert it as a 
regular text field by adding the following line to the [CONV] section of the file 
VA2.INI:  
ProcedureToForm = N 
 

7. Due to differences between VA 1.50 and VA 2, some fields cannot be converted in a 
straight forward manner,  and are adjusted as follows: 

a.  Risk 
Standard Conversion method: For each objective, the risk factors of the objective 
are copied into the factors of the risk question attached to it.  The “higher risk” 
criteria are copied into the criteria.  The risk rating of the objective is mapped into 
the risk of the risk level question as follows: 
High = Zone 9  (Impact 5, Likelihood 5) 
Medium = Zone 5  (Impact 3, Likelihood 3) 
Low = Zone 1  (Impact 1, Likelihood 1) 

ERM method: The risk factors of the objective are copied into the factors of each 
risk question attached to it.  The “higher risk” criteria are copied into the criteria 
for each risk question.  The VA 1.50 consideration responses are mapped into both 
the Risk and Exposure of the corresponding risk question as follows: 

? = Incomplete 
No (Importance>= Key Control Importance) = Zone 7  (Impact 4, Likelihood 4) 
No (Importance< Key Control Importance) = Zone 6 (Impact 4, Likelihood 3) 
Part = Zone 5  (Impact 3, Likelihood 3) 
Yes (Importance>= Key Control Importance) = Zone 4  (Impact 3, Likelihood 2) 
Yes (Importance< Key Control Importance) = Zone 3  (Impact 2, Likelihood 2) 
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b.  Consideration “Text” response 
“Text” responses are mapped to “Part” responses.  The text field is mapped to 
“Control Comment” which is the text field of the form for this level. 

c.  Components 
Only the components: Operational, Financial and Compliance are converted to VA 
2.  Components are assigned at the objective level in VA 2 by gathering the 
components of the considerations that are attached to the objective. 

d.  Area response, objective response, scoring 
These are not used in VA 2. 
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To convert your Knowledgebases, do the following: 

1. Complete the steps given in Chapter 8 - Database Integrity Check Program. 

2. If instructed to in our email, download the Database Integrity Check 
installation program. 

3. Select RUN from the Windows start menu and locate the file you downloaded 
by clicking on the <Browse> button, then click the <OK> button. 

 
Note: 
The CONVERT program is a single-user license only.  As such, it may ONLY be 
installed on one computer.  The installation is password protected.  If you require 
this version, the password may be obtained by contacting: 

Technical Support between 9.00 a.m. and 5.00 p.m. (EST in the USA; 
GMT in the UK), Monday through Friday, excluding holidays. 

              USA                UK 
Address: Kilclare Software Kilclare Software Ltd 
 49 Grandview Road 1st Floor Dammas House 
 Arlington Dammas Lane 
 MA 02476 Swindon  SN1 3EJ 
 USA Wiltshire 
  United Kingdom 
   
Telephone: +1 (781) 648 5156 +44 (0) 1793 616685 
   
Facsimile: +1 (781) 648 6757 +44 (0) 1793 616690 
 
Web Site: http://www.kilclare.com 

E-Mail:  techsupport@kilclare.com 
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The Convert Program uses the InterSolv ODBC drivers.  The InterSolv ODBC 
drivers will correctly convert any international characters used in your VA1.5 
Knowledgebases (e.g. French, Swedish etc). 

4. Follow the on-screen instructions. 

5. Install ALL legacy VISUAL Assurance 1.5 Knowledgebases on the System. 

6. Start up the CONVERT program. 

7. In the left-hand panel, select the legacy Knowledgebases you wish to convert 
from the VA 1.5 FoxPro format to the new Client/Server format.  Highlight the 
Knowledgebase and then click the <Select> button. 

8. Click the <Convert> button to start the conversion. 
The conversion progress is shown in the lower half of the Convert Program 
screen.  Note that as Knowledgebases are converted they are grayed out in the 
left hand panel and appear in the right hand panel. 

9. Once the conversion has completed, a message box will display.  Click the 
<OK> button. 

10. To exit the CONVERT program, click the <Close> button. 
 
Note: 
If the CONVERT program is interrupted, for whatever reason, then you may 
restart it and it will continue from where it left of. 
On restart, Knowledgebases that have already been successfully converted are 
they are grayed out in the left hand panel and appear in the right hand panel. 

11. You may then continue to work on VISUAL Assurance. 

34 Kilclare Limited 



Installation Guide 

InterBase Server Manager 

10 

Your data is valuable and you are responsible for its integrity and seeing that it is 
well maintained.  Although this chapter describes the Local InterBase utility, 
IBMGR32.EXE, other vendors have similar utilities and you should refer to your 
Client/Server Database vendor’s documentation. 

The standalone installation includes the Borland Local InterBase Client/Server 
Database.  By Default, InterBase is installed in folder \Program Files\InterBase 
Corp.  In sub-folder InterBase\bin you will find a utility, IBMGR32.EXE.  
IBMGR32 will help you maintain the integrity of your data.  IBMGR32 also allows 
you to purge your database of deleted records.  Purging your database will reduce 
its size. 

NOTE: 

By combining the Backup and Restore procedures described below, your 
database will be purged of any deleted records and the size of the file, 
VADB.GDB, will be reduced. 

Local InterBase Client/Server Integrity Check 
To check the integrity of your database, do the following: 

1. Execute the InterBase Server Manager, IBMGR32.EXE, which is in the 
folder \Program Files\InterBase Corp\InterBase\bin. 

2. Click the Server Login icon (the first icon from the left). 

3. The InterBase Login screen is displayed.  In the “Server Info” group, enter 
“SYSDBA” in the “User Name” field and “masterkey” in the “Password” field.  
Then click the <OK> button.  If this is not the first time you are using 
IBMGR32 then the “User Name” field will already be completed. 
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4. Click the Database Connect icon (the third icon from the left). 

5. The Connect to Database screen is displayed.  In the “Database” field either 
browse to the file VADB.GDB (which is usually in folder 
C:\VA32\DATABASE) or enter the complete path and file name.  Then click 
the <OK> button.  If this is not the first time you are using IBMGR32, then you 
may be able to accept the current contents. 

6. Click the Database Validation icon (the second last icon). 

7. The Database Validation screen is displayed.  Check the “Validate record 
fragments” field and then click the <OK> button. 

8. If there are no database errors you will be so advised.  If there are, click the 
<Repair> button and repeat steps 6 and 7 above.  If errors persist, repeat steps 6 
and 7 again.  If errors still persist then continue with the steps 9 and 10 below 
and then follow the Backup/Restore procedures in the following sections. 

9. Click the Database Disconnect icon (the fourth icon from the left). 

10. Click the Server Logout icon (the second icon from the left).  Click the <Yes> 
button when prompted. 

11. Exit IBMGR32, File->Exit. 

Local InterBase Client/Server Backup 
To Backup your database, do the following: 

1. Execute the InterBase Server Manager, IBMGR32.EXE, which is in the 
folder \Program Files\InterBase Corp\InterBase\bin. 

2. Click the Server Login icon (the first icon from the left). 

3. The InterBase Login screen is displayed.  In the “Server Info” group, enter 
“SYSDBA” in the “User Name” field and “masterkey” in the “Password” field. 
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Then click the <OK> button.  If this is not the first time you are using 
IBMGR32 then the “User Name” field will already be completed. 

4. Click the Database Connect icon (the third icon from the left). 

5. The Connect to Database screen is displayed.  In the “Database” field either 
browse to the file VADB.GDB (the default installation folder is 
C:\VA32\DATABASE) or enter the complete path and file name. Then click 
the <OK> button.  If this is not the first time you are using IBMGR32, then you 
may be able to accept the current contents. 

6. Click the Backup icon (the sixth icon from the left). 

7. The Database Backup screen is displayed.  In the “Backup File or Device” 
field, enter the full path and name of the file to be used.  Then click the <OK> 
button. 

8. A screen displaying the progress of the backup will be displayed.  Close this 
screen once you have satisfied yourself that all went well. 

9. Click the Database Disconnect icon (the fourth icon from the left). 

10. Click the Server Logout icon (the second icon from the left).  Click the <Yes> 
button when prompted. 

11. Exit IBMGR32, File->Exit. 

Local InterBase Client/Server Restore 
To Restore your database, do the following: 

1. Execute the InterBase Server Manager, IBMGR32.EXE, which is in the 
folder \Program Files\InterBase Corp\InterBase\bin. 

2. Click the Server Login icon (the first icon from the left). 
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3. The InterBase Login screen is displayed.  In the “Server Info” group, enter 
“SYSDBA” in the “User Name” field and “masterkey” in the “Password” field. 
Then click the <OK> button.  If this is not the first time you are using 
IBMGR32 then the “User Name” field will already be completed. 

4. Click the Database Connect icon (the third icon from the left). 

5. The Connect to Database screen is displayed.  In the “Database” field either 
browse to the file VADB.GDB (the default installation folder is 
C:\VA32\DATABASE) or enter the complete path and file name. Then click 
the <OK> button.  If this is not the first time you are using IBMGR32, then you 
may be able to accept the current contents. 

6. Click the Restore icon (the seventh icon from the left). 

7. The Database Restore screen is displayed.  In the “Backup File or Device” 
field, enter the full path and name of the file to restore from (this is a previously 
backed up file).  In the “Primary Database File” field, enter the full path and 
name of the file to restore to (this is a GDB file).  Then click the <OK> button.  
DO NOT RESTORE TO THE VADB.GDB FILE – First restore to another file 
name, then check the restored files integrity, only once the database integrity 
check proves satisfactory should you replace your working VADB.GDB file 
with the new file. 

8. Click the Database Disconnect icon (the fourth icon from the left). 

9. Click the Server Logout icon (the second icon from the left).  Click the <Yes> 
button when prompted. 

10. Exit IBMGR32, File->Exit. 
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Setting Up Users with LAN Workstation Software 

11 

This section is for Network Administrators who wish to set up Users with the aid of 
LAN Workstation software.  

Files are copied to your WINDOWS\SYSTEM folder.  The installation program 
automatically detects the location of your Windows folder. 

The values are added to the Registry (E.g. program version, uninstall information 
and shared DLL information). 

An existing Borland Database Engine installation will be upgraded, only if it is 
found to be an earlier version.  A 32 bit version will be upgraded to version 5.2. 

VA2.INI 

This file should be copied from the Administrator’s WINDOWS folder to each of 
the users WINDOWS folder. 

The values of LocalInf and ServerInf should be changed to reflect the drive and 
folder name of the location of the files VALOCAL.INF and VASERVER.INF 
respectively.  Either or both LocalInf and ServerInf may be in the VA2.INI file.  
The LocalInf entry is for a Single-User installation and the ServerInf entry is for a 
Workstation installation.  VALOCAL.INF and VASERVER.INF are updated by 
the utility VADBPASS.EXE.  See Chapter 6 - Database Installation/Setup, for 
more information regarding VADBPASS.EXE. 
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